When the environment starts, a window is displayed: "Cannot find one or more components. Please reinstall the application." And that's all. Reinstallation does not help, I tried to reinstall several times directly, and delete everything with the help of Revo Uninstaller, it does not save anything. Viewed from the Dependency walker on the missing libraries - everything is in place. System updates are installed. System - Windows XP SP3. The product is Microsoft Visual Studio 2010 Ultimate, but the same problem with Professional.

Immediately I inform you: installing previous versions or other environments is not an option.

  • Something here does not like her in XP, maybe you will put the seven? - rojaster
  • Immodest question - do you put a pirate? I can say one thing: the 2010th worked for me exactly, but after I put all the options from the disk. In addition, I put on the 2003 server, and not on XP. Although, in general, the OS for the house are the same. - gecube
  • Reply to all comments: The studio used to work. Although about the piratchiny ... I downloaded an image from the Web, there was also a key there. But, again, for some time the studio worked. And immediately: whether the network is turned on or not, the result is the same: an error with shutdown, that is, verification of the code over the network is clearly not connected with this. - 3JIoi_Hy6 pm

3 answers 3

in the folder C: Program Files Microsoft Visual Studio 10.0 Microsoft Visual Studio 2010 Express for Windows Phone - ENULogs are the logs of installation and operation; there should be more detailed information about your error (do not pay attention to my version of VS, you should have the appropriate one)

  • I have the following address at C: \\ Program Files \\ Microsoft Visual Studio 10.0 \ Microsoft Visual Studio 2010 Ultimate - ENU \\ logs are only installation logs. When checking these logs, nothing seemed to alert me. In case I renamed the logs folder to logs000 and started the environment: what if there is a new logs folder with the launch log. Nothing: no studio work logs seem to have time to create ... - 3JIoi_Hy6
  • still such nuance: on XP 64 bit it does not work. I hope you do not have 64 bit? - LackOfKnowledge
  • Not. And, again, Wednesday worked before. But after what actions I stopped working - I do not remember))) ... - 3JIoi_Hy6
  • computersplace.net/articles-review/..that this is a problem with the ATL90.dll file but there is a studio 2008, and you have 2010, and indeed there may be another problem. But still try, suddenly it will work out - LackOfKnowledge

Try reinstalling not the studio, but the .Net Framework.

  • when installing the studio, the necessary .NET framework is also installed - LackOfKnowledge

Everything turned out a little different. The native installer is in C: \ Documents and Settings \ __ ALEX \ Desktop \ X16-42552VS2010UltimTrial1. From there I installed everything. Finally I found the setup.exe file in C: \ Program Files \ Microsoft Visual Studio 10.0 \ Microsoft Visual Studio 2010 Ultimate - ENU \ setup.exe. I decided to launch it at last: there is nothing to lose. It is not strange, after the next complete reinstallation earned! True, what is the difference, I did not understand.